Client Login

We keep our clients secure!

We keep our clients secure!

Effectively this year, all major Grade "A" Browsers (Chrome, Firefox, Internet Explorer) will no longer support certain types of SSL Certificates.

Critically Important Information


Effectively this year, all major Grade "A" Browsers (Chrome, Firefox, Internet Explorer) will no longer support certain types of SSL Certificates. This is the mechanism in how we secure customer transmittal over the Internet.

Effective Now
All Valiant certificates have been reviewed and updated where needed. They all comply with the latest standards. There may be service interruptions and impact to Customers using extremely outdated Operating Systems.

For clients which have new ( Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Mac OSX, etc ) operating systems along with new versions of Web Browsers. This does not present as a problem.

The issue is with Customers which have extremely outdated PC's, over 10 years old, which are running Windows XP or Windows Millennium ( Me ). These Operating System versions do not support the latest Citrix Receivers 4.X which are required to use this new more modern SSL Certificates.

Hence it is imperatives that clients which have extremely outdated PC's upgrade so that they may continue to connect to Valiant' Systems. As currently estimated this is less than 4% of our entire user base. These may in fact also be older "home" pc's or similar equipment.

In Summary
Valiant is requesting that Clients perform an upgrade of the Citrix Receiver client for the following reasons:
  • Sun-setting of support for Low SSL Key Certificates in most Major Browsers
  • As of April 8th, 2014 Microsoft has stopped support for Windows XP - End of Life
  • Citrix is sun-setting support for older version of Citrix Receiver